my cheat sheet on reasonably good initial router configs

Home

1 Start with this:


hostname r2

ip domain-name   zintis-lab
aaa new-model
aaa authorization exec default local

int gig 0/3
  ip vrf forwarding mgt
  ip addr dhcp
  no shut


line vty 0 4
transport input all
password Cisco12345
login
privilege level 15
exec-timeout 15


line con 0
privilege level 15
exec-timeout 15


username zintis privi 15
username zintis  password Cisco12345
Username zintis  role network-admin


crypto key gen rsa




ip ssh version 2
---------------

 vrf definition mgt
  ! 
  address-family ipv4 
  exit-address-family 
  ! 
  address-family ipv6 
  exit-address-family 

 interface GigabitEthernet0/3
  vrf forwarding mgt 
  ip address dhcp 
  negotiation auto 

 ip route vrf mgt 0.0.0.0 0.0.0.0 192.168.128.1 

1.1 Home